pipeline-model-declarative-agent : 0.8.2

Description

API for declarative agents in Declarative Pipeline

Summary

No other software package is referencing this project.
That doesn't mean anything. But in general references from other packages are a good sign.
This version number (0.8.2) fits semantic versioning 2.0.0!

Dependencies

2 Compile Dependencies
Dependency Badge

8 Test Dependencies
Required Newest
javax.servlet:javax.servlet-api 3.1.0 3.1.0
junit:junit 4.12 4.12
org.jenkins-ci.main:jenkins-test-harness 2.15 2.18
org.jenkins-ci.main:jenkins-war 2.7.1 2.40
org.jenkins-ci:test-annotations 1.2 1.2
org.slf4j:jcl-over-slf4j 1.7.7 1.7.22
org.slf4j:log4j-over-slf4j 1.7.7 1.7.22
org.slf4j:slf4j-jdk14 1.7.7 1.7.22

7 Provided Dependencies
Required Newest
com.google.code.findbugs:annotations 3.0.0 3.0.1u2
commons-logging:commons-logging 1.1.3 1.2
javax.servlet:servlet-api 2.4 3.0.1
log4j:log4j 1.2.17 1.2.17
net.jcip:jcip-annotations 1.0 1.0
org.codehaus.mojo:animal-sniffer-annotations 1.14 1.15
org.jenkins-ci.main:jenkins-core 2.7.1 2.40

Maven

pom.xml snippet for Maven
<dependency>
    <groupId>org.jenkinsci.plugins</groupId>
    <artifactId>pipeline-model-declarative-agent</artifactId>
    <version>0.8.2</version>
</dependency>
Gradle
'org.jenkinsci.plugins:pipeline-model-declarative-agent:0.8.2'
Ivy (Ant)
<dependency org="org.jenkinsci.plugins" name="pipeline-model-declarative-agent" rev="0.8.2" />
SBT (Scala)
libraryDependencies += "org.jenkinsci.plugins" % "pipeline-model-declarative-agent" % "0.8.2"
Leiningen (Clojure)
[org.jenkinsci.plugins/pipeline-model-declarative-agent "0.8.2"]


1 Repository
https://repo.jenkins-ci.org/public/

Leave a comment

Sign in to leave a comment.