Ruby/lingq/0.3.1


Gem for interacting with the API of lingq.com. It's a language learning website, and it's pretty useful, but I want to be able to work on my flashcards offline. This gem is being written to be included in a desktop client (and maybe eventually a mobile client), but will certainly still be useful as a standalone api wrapper for other projects that want to interact with Lingq.com

https://rubygems.org/gems/lingq
UNKNOWN

1 Security Vulnerabilities

lingq Gem for Ruby client.rb Metacharacter Handling Remote Command Execution

Published date: 2014-06-30
Links:

lingq Gem for Ruby contains a flaw in client.rb that is triggered when handling metacharacters. This may allow a remote attacker to execute arbitrary commands.

Affected versions: ["0.3.1", "0.3.0", "0.2.1", "0.2.0", "0.1.4", "0.1.1"]
Secure versions: []

6 Other Versions

Version License Security Released
0.3.1 UNKNOWN 1 2010-06-21 - 14:28 about 14 years
0.3.0 UNKNOWN 1 2010-06-21 - 14:24 about 14 years
0.2.1 UNKNOWN 1 2010-06-19 - 17:48 about 14 years
0.2.0 UNKNOWN 1 2010-06-19 - 17:46 about 14 years
0.1.4 UNKNOWN 1 2010-06-19 - 17:13 about 14 years
0.1.1 UNKNOWN 1 2010-06-19 - 17:08 about 14 years